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 Revision 0.9.3 2/7/04 Essentials of FrameMaker • vii

Preface

Forward

I love FrameMaker. One of my favorite things to do with FrameMaker is to
solve a previously unsolved problem. The fun part of this is learning
something new about FrameMaker. Some might question my idea of fun but
this is how I learned about FrameMaker, under pressure of a deadline and
without formal training.

After I learned how to use FrameMaker, I wanted to know why things worked
the way they did. I could only do so with an enquiring, patient mind, willing to
make mistakes and learn from them. Everything I present in this manual
comes out of that learning process. I hope you too will approach learning and
using FrameMaker with an enquiring mind, willing to make mistakes and learn
from them.

I designed this manual to teach a computer-literate person how to use
FrameMaker at an everyday, fundamental level. Rather than teach how each
tool is used, which requires users to integrate that information to get their work
done, I show how to use all the tools in an integrated manner, at a specific
level. This task-based, or usage-level-based concept was borne out of
thousands of hours of training new users, setting up new FrameMaker
installations, and troubleshooting existing FrameMaker installations. I realized
that FrameMaker is almost exclusively used in a corporate environment, in
which a template usually exists. Thus most users use the existing formats and
do not create new formats, let alone entire templates.

I divided FrameMaker tasks into multiple levels of complexity, the most basic
being this manual Essentials of FrameMaker, which is the most fundamental
level of usage—writers using FrameMaker to produce documents with
existing templates.

I hope you enjoy this manual. If you have any questions or problems, please
contact me at: fm101@meta-phrase.com

Doug Martin

Overview

Each chapter in this manual is self-paced and can be done with or without a
trainer.

When you have completed the exercises in the nine chapters of this manual,
you will have created a book with a cover page, copyrights and disclaimers,
table of contents (TOC), four chapters, and an index.
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Intended Audience

Essentials of FrameMaker is the first volume in the Foundations of
FrameMaker series. As its name implies, it provides an overview of the aspects
and tools that are essential to using FrameMaker. Essentials of FrameMaker is
intended for a new user coming into an established FrameMaker installation
with pre-defined templates. The Template Administrator controls the formats
in the templates and ensures that users do not modify any formats. This
manual explains how to use predefined formats in their intended manner.
Creating and modifying formats is taught in subsequent courses, such as
FM 301: FrameMaker Template Creation and Administration (Basic and
Intermediate Template Design Skills) and FM 551: Big Docs Made Easy.

Conventions

There are specific conventions used to present the information in this manual.
This section outlines the formats and reasons for presenting the information
using these conventions.

Exercise 1 Explanation of Information Presentation

An Exercise contains a series of steps to create the effect or to carry out the
procedure discussed in the text above the Exercise or in a paragraph under the
heading, just as this text is doing here.

1 The steps give specific instructions to be carried out.

2 If the step is complex, it is explained with general instructions here; detailed
instructions are listed below the general instruction.

a. This substep explains a complex step in smaller pieces.

b. This means that if you read the main description of the action to be taken
in the step above

c. and then see similar text below in substeps, it does not mean to do it twice.

d. The substeps simply give detailed instructions to someone who may not be
familiar with the given action(s).

Order of Exercises

Throughout this book, the knowledge you glean from one chapter frequently is
built on and expanded in subsequent chapters. In order to understand the
information presented in this book, you may wish to complete the entire book
before performing exercises out of order.
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Dialog Box Differences

FrameMaker dialog boxes have different appearances for each of the three
main operating systems. For this course, the primary differences are how the
option selection states are displayed in dialog boxes and windows and how
that state is noted in text.

Some options have only two states; when text refers to an option’s selection
state, On will be noted as check (select) and Off will be noted as uncheck
(deselect).

Pathnames and File Storage Locations

We use the UNIX syntax to list pathnames (such as /work/fm101 rather
than C:\work\fm101). Since two of the three main operating systems, the
three main markup languages (SGML, HTML, and XML), and the internet use
this syntax, we also use it here.

In this book, we use the UNIX term directory rather than the Windows
and Macintosh term folder to denote storage locations on your hard drive.

Some resources are located in the FrameMaker installation directory; since the
location of this directory varies depending on the platform, we use the
generalization of ../<FrameMaker-install-dir>/ to point to one of
three locations:

Thus, to refer to the ClipArt directory in the FrameMaker installation
directory, we use this notation: ..<FrameMaker-install-
dir>/clipart.

Option
Selection State

Macintosh UNIX (Sun
OpenWindows)

Windows

On

As Is

Off

Platform Pathname

Mac <hard-drive>:Applications:Adobe:FrameMaker

UNIX $FMHOME/fminit/<langdir>/

Windows C:\Program Files\Adobe\FrameMaker
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Formatting Conventions

This book contains many exercises that require the reader to enter or
understand information. To make clear what is required of the reader at a given
point, various formats are used and are explained in the following table:

Keyboard Key Names Used

In this book, most keys are referred to by their common names, such as Alt,
Backspace, Command, Control, Delete, Meta, Option, Shift, Tab

Other keys, such as Return or Enter are referred to by the UNIX term Return.

Format Meaning Example

Action Emphasizes an action to be performed by the
reader or the most important part of the step

Paste the marker

Bold Indicates text that was previously entered and
now must be altered. This makes it easier for
readers to locate the parts to be changed

(changed text is shown in Bold):

<$startrange>Michael
Faraday[Faraday]

Button Emphasizes a button to be clicked Click Change

code Indicates a code fragment such as a building
block

Insert the <$chapnum> building
block

Entry Indicates text to be selected or typed Type: Header/FooterLine

Filename Identifies a filename Open local-template.fm

Format
Name

Indicates the name of a format, paratag,
chartag, tabletag, master page, or reference
page

Assign the TitlePage4-2Line
master page

Keyname Emphasizes a key to be pressed Press Tab twice

Menu Emphasizes a specific menu selection From the Graphics menu, select
Object Properties

Option Identifies an option in a dialog box to be
selected

In the Show/Hide Conditional Text
dialog box, select Show All

PopUp
MenuItem

Identifies a selection in a pop-up menu From the Commands pop-up menu,
select New Format

Property Identifies a property in a dialog box or
designer

Go to the Bookmarks properties

Shortcut Indicates a keyboard shortcut Use the keyboard shortcut, !ocl

Toolname Indicates a FrameMaker tool Using Find/Change, find the text
FigAbove
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Keyboard Shortcut Notation Explanation

Many of the functions and tools of FrameMaker can be selected or controlled
using keyboard shortcuts. Some of these keyboard shortcuts use the various
specialized keys Alt, Command, Control, Meta, and Option and are
different for each platform.

Some keyboard shortcuts can be used on all three platforms, Macintosh,
UNIX, and Windows. These “cross-platform” keyboard shortcuts are triggered
by a sequence of keys starting with the Esc key. Shorthand UNIX notation for
the Esc is the exclamation point ( ! ), commonly called “bang.” The keyboard
shortcuts mentioned in this manual that use the Esc key, are listed using this
shorthand notation look like this:

!ocl

This means to press and release the Esc key, then press and release the
following keys in succession: lower-case O, lower-case C, and lower-case L.
By the way, pressing these keys opens the Column Layout dialog box.

Installing Applications, Files, and Directories

You will need to perform a complete installation of FrameMaker (which will
install Acrobat Distiller) and Acrobat, or Acrobat Reader. If you are attending
this class on-site or in a training center, this has been done for you.

Find a place in your computer system where you can store the (approximately)
5MB of files you’ll be using while performing the exercises in this book.

Note: Use the exercise appropriate for your operating system. If you are attending
this class on-site or in a training facility, skip this exercise. The following steps have
already been done for you.

Exercise 2 Create Macintosh Working Directory

Note: You’ll need StuffitExpander to uncompress the archive in this exercise. If you
don’t have StuffitExpander you’ll have to download the uncompressed files.

1 Download the class files from http://www.meta-phrase.com /
downloads / download.html. Click on fm101 to go to the link and
select your platform to download the appropriate archive.

2 Save the fm101.sit archive to a folder on your hard drive. This can be the
desktop or your root directory.

3 Double-click the fm101.sit archive.
StuffitExpander will unstuff the archive to the folder and create the fm101
directory. When you create documents or books, you will save them to the
../fm101/ directory.
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4 You may delete the fm101.sit archive.

5 Each of the various chapter directories, such as ../fm101/ch3 or
../fm101/ch4, contain all the files you will need to complete the exercises
for the corresponding chapter. That is, ../fm101/ch3 contains the files
needed to complete the exercises in Chapter 3, and ../fm101/ch4 contains
the files needed to complete the exercises in Chapter 4. We recommend that
you complete all the exercises in sequence at least once before completing
chapters out of order.

6 Store an alias to ../fm101/e-templates in the FrameMaker Templates
directory, which is inside the FrameMaker installation directory. Create an
alias of your e-templates directory, ../fm101/e-templates, and
move it to the FrameMaker Templates directory inside ../<FrameMaker-
install-dir>/.
(For more information about the location of the FrameMaker installation
directory, see Pathnames and File Storage Locations on page ix.)

7 Confirm the installation of the alias to the e-templates directory.

a. From within FrameMaker, from the File menu, select New > Document.
The New Document dialog box FrameMaker should look like the
following:

Exercise 3 Create UNIX Working Directory

Note: You’ll need gzip to uncompress the archive in this exercise. If you don’t have
gzip you’ll have to download the uncompressed files.

1 Download the class files from http://www.meta-phrase.com /
downloads / download.html. Click on fm101 to go to the link and
select your platform to download the appropriate archive.

The e-templates
alias has a special
appearance in the
Templates directory
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2 Save the fm101.tar.gz archive to a temporary directory.

3 Unzip the archive in the temporary directory using the following command:
gunzip -v fm101.tar.gz

This will unzip the archive into the temporary directory and leave a tar file,
fm101.tar

4 Extract the files using the following command:
tar -xvf fm101.tar

This will install them into a directory named /work/fm101. You may then
move the fm101 directory to a location of your choosing. This location will be
noted throughout the remainder of this manual as ../fm101/. When you
create documents or books, you will save them to the ../fm101/ directory.

5 Each of the various chapter directories, such as ../fm101/ch3 or
../fm101/ch4, contain all the files you will need to complete the exercises
for the corresponding chapter. That is, ../fm101/ch3 contains the files
needed to complete the exercises in Chapter 3, and ../fm101/ch4 contains
the files needed to complete the exercises in Chapter 4. We recommend that
you complete all the exercises in sequence at least once before completing
chapters out of order.

6 Create a symbolic link from the
$FMHOME/fminit/<langdir>/Templates directory to your e-
templates directory, ../fm101/e-templates. (The <langdir> is
the directory for your platform language; for example, if you installed a US
English version of FrameMaker, <langdir> would be usenglish.) This
command should look like:

ln -s $FMHOME/fminit/<langdir>/Templates
../fm101/e-templates

7 Confirm the installation of the symbolic link to the e-templates directory.

a. Start FrameMaker.
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b. From the File menu, select New > Document.
The New dialog box
FrameMaker should look like
the following:

Exercise 4 Create Windows Working Directory

Note: You’ll need WinZip to uncompress the archive in this exercise. If you don’t have
WinZip you’ll have to download the uncompressed files.

1 Download the class files from http://www.meta-phrase.com /
downloads / download.html. Click on fm101 to go to the link and
select your platform to download the appropriate archive.

2 Save the fm101.zip archive to a temporary directory.

3 Open the fm101.zip archive to extract the folders within the fm101.zip
archive to ../fm101/

a. Open the fm101.zip archive by double-clicking the fm101.zip file
icon.

b. WinZip starts and displays the files in fm101.zip.

c. From the Actions menu, select Extract.

d. In the Extract To: box, specify the path to where you want to store the
fm101 folder. For example, to store it on the C: drive, enter: C:\
To store it in D:\downloads\work, enter D:\downloads\work\

For the rest of this manual, the directory you choose is referred to as
../fm101/. When you create documents or books, you will save them to the
../fm101/ directory.



 Preface
Create Windows Working Directory

Revision 0.9.3 2/7/04 Essentials of FrameMaker • xv

4 Unlock the files before using them. In the ../fm101/ directory, double-click
unlock.bat.
This will ensure that all the files are unlocked.

5 Each of the various chapter directories, such as ../fm101/ch3 or
../fm101/ch4, contain all the files you will need to complete the exercises
for the corresponding chapter. That is, ../fm101/ch3 contains the files
needed to complete the exercises in Chapter 3, and ../fm101/ch4 contains
the files needed to complete the exercises in Chapter 4. We recommend that
you complete all the exercises in sequence at least once before completing
chapters out of order.

6 Create a “shortcut” of your e-templates directory, ../fm101/e-
templates. Copy it and paste it in the FrameMaker Templates directory
(typically, C:\Program
Files\Adobe\FrameMaker 7.0\Templates).

7 Confirm the installation of the shortcut to the e-templates directory.

a. Start FrameMaker

b. From the File menu, select New > Document.
The New dialog box FrameMaker should look like the following:

Thee-templates
directory displays
as another folder in
the Templates
directory
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Introduction

FrameMaker is unlike word-processing or page layout applications because it
was designed to create long, complex documents composed of multiple
separate files; FrameMaker is a document processor.

Objectives

In this chapter you will:

• Compare FrameMaker to other applications

• Understand the FrameMaker approach to document processing

• Learn about Global Management of Styles and Formats

• Take a brief tour of the FrameMaker interface

• Learn the names and locations of FrameMaker’s tools

• Set up application preferences and document viewing options

How FrameMaker Differs From Other Applications

FrameMaker is a document processing application that allows users to easily
create and maintain long, complex documents. Other desktop publishing
(DTP) applications appear to be similar to FrameMaker, but lack
FrameMaker’s sophisticated and integrated tools. For example, Microsoft
Word© is a text processor and was designed to format short, simple
documents, such as office correspondence or white papers. Adobe
PageMaker© is a page-layout tool, suitable for creating four-color brochures,
catalogs, and newsletters, where absolute control over individual page layout
is paramount.

1Getting Started in
FrameMaker 7
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The following table outlines some of the differences between FrameMaker and
other DTP applications used to create long manuals.

FrameMaker tool Compared to similar MS Word
tool

Compared to similar
PageMaker tool

Paragraph Formatting Styles Styles

Paragraph Formats are
completely customizable. Major
difference is autonumbering:
absolute control of when
numbers increment and when
numbers are reset. Also,
graphics can be part of a
Paragraph Format.

Pre-set autonumbering styles
Not easily controlled;
autonumbering can be
unreliable.
No global control of paragraph
formats across documents.

Has good typographic controls.
Pre-set autonumbering styles
are not easily controlled;
autonumbering can be
unreliable. No global control of
paragraph formats across
documents.

Character Formatting Styles No matching tool

Character Formats allow global
control of individual character
formatting using Character Tags.

Styles in Word are similar to
Character Formats, but only
within a document. No global
control of characters across
documents.

Cannot globally control
character formatting.

Color

Can create custom colors for 4/c
work and use predefined
Pantone, Toyo, Trumatch, and
other industry-standard color
libraries.

No color libraries. Can create custom colors for 4/c
work and use predefined
Pantone, Toyo, Trumatch, and
other industry-standard color
libraries.

Table of Contents

Define TOC content by
Paragraph Formats; TOC
created from within book of
multiple files or for individual
document. The resulting TOC is
a separate document.

Define TOC by style or by
specialized tagging. TOC
created for individual files or for
master document.

Must select paragraph to be in
TOC in paragraph specification
box.

Long Document Creation

Long document creation is
effortless. FM designed to
handle multiple files to create
one logical document. Multiple
files can be effortlessly moved
around within the Book window.

Word designed to handle single
documents. Can use master
document to organize logically
related files, but interface is
clumsy.

Long document creation difficult.

(Sheet 1 of 3)
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FrameMaker tool Compared to similar MS Word
tool

Compared to similar
PageMaker tool

Index Entries

Index entries can be formatted
with any character format, can
have any number of levels.
Completely customizable.

Index entries must be marked
with special code. Limited to two
levels with pre-defined
formatting.

Index entries limited to specific
formats and only three levels.

Index Formatting

Index formatting controlled in
the Index file and is user-
defined; no limits to complexity
of formatting and all formats can
be changed in one place.

Entries are limited to pre-
defined formats. Formatting of
indexes limited to predefined
formats.

Indexes are generated for each
file.

Generated File Types

FM has thirteen different
generated file types, including
standard TOC and IX.
All generated file information
stored on Reference Pages for
easy global control of formatting.

Word has four standard
generated files: Index, TOC, List
of Figures, List of Authorities.

PM has only TOC and Index.

Cross-References

FrameMaker allows unlimited
user-defined formats; can be
arbitrarily complex. Can cross-
reference to any other FM
document that is open on
desktop.

Limited cross-referencing ability.
Source type limited to pre-
selected paragraph styles.
Content and format are limited.
Cannot cross-reference another
document.

Cross-referencing limited to
entries in index.

Tables

Table formats can be created
and applied to any table.
Unlimited number of table
formats; precisely control
position, size, row height, ruling,
etc. Paragraph styles, defined
and controlled from one place
are used within tables, and allow
global control of text
appearance within table cells.

Limited number of pre-defined
table formats.
No global control of tables
styles.

PM uses stand-alone table
editor; tables are created in
Adobe Table and imported into
PM.
No global control of tables
styles. Formatting within table
cells limited to typographic
controls; bold, italic, caps,
indents, alignment.

(Sheet 2 of 3)
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FrameMaker’s tools easily manage separate physical files that comprise one
logical file. Most importantly, formats can be administered across all the
documents that comprise the logical file. This management of formats can be
extended to allow global management of an arbitrary range of documents and
document sets.

Global Management of Formats

Global management of formats is crucial to produce documentation with a
uniform appearance. Document sets that have a uniform appearance reflect a
well-organized and attentive-to-detail enterprise.

How formats are globally managed in FrameMaker

Your organization might produce many different “types” of documents, such
as white papers, employee training manuals, product specification manuals,
field service manuals, user guides, workflow or process manuals, user training
materials, reference manuals, technical manuals, and others.

To create a specific “type” of document, you would use a FrameMaker
template that was created to produce that “type” of document. For example,
your organization might create two software user manuals, a user guide and a
technical reference manual. The user guide might have different formatting
requirements than the technical reference manual. Therefore, you would create
two templates, one for the user guide and another for the technical reference
manual.

FrameMaker tool Compared to similar MS Word
tool

Compared to similar
PageMaker tool

Variables

Variables define and control
appearance of text strings in
one place. Use in many places;
when changed, each point of
usage is automatically changed
as well.

No comparable tool (Autotext
feature allows creation of a
Variable-like string, but cannot
update previously inserted
instances when Autotext string
is modified).

No comparable tool in PM.

Master Pages

Master Pages globally control
appearance of document layout.

No comparable tool.
Each page laid out separately.

Master Pages globally control
appearance of document layout.

Editing Structured Documents (SGML and XML)

Can create DTDs and
SGML/XML instances from
structured documents.

Custom application required to
edit XML. Need separate
application to create DTD.

No comparable tool.

(Sheet 3 of 3)
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Each of these templates may comprise several FrameMaker files stored in a
book. The templates will contain specific layouts and definitions of the formats
available in FrameMaker. The documents produced from those templates also
will be stored in FrameMaker books.

Most documents are revised periodically over a lifespan of many months or
years. These documents are often referred to as “living documents.”

The big issue with living documents is how to maintain the formats across all
the documents that are the same type, such as the user guide or technical
reference manual. To manage the formats for all the documents that are the
same type, you create another specialized type of template, generally called a
Master Template. The Master Template controls not only the documents
created from the template, but the template itself.

When the formats need to be revised, rather than revise them in each document
file, you revise them in one place, the Master Template. Then import the
formats from the Master Template into another specialized document called a
Local Template. The Local Template controls the formats and variable
definitions that are used within a specific FrameMaker book. This hierarchy
can be represented with a tree diagram, as shown below:

One problem with global management of formats is that FrameMaker also
allows users to modify formats within individual documents.

The crux of global management of formats is using only the formats created in
and controlled by the Master Template. If a format is introduced in a document
that is not stored in the Master Template, the style cannot be globally
managed. Documents created using these non-standard formats look different
from the template.

Corporate
Master

Template

Field
Service
Manual
Master

Template

Technical
Reference

Master
Template

Reference
Manual
Master

Template

Process
Manual
Master

Template

User Guide
Master

Template

Product 1
User Guide

Local
Template

Product 2
User Guide

Local
Template

Product 3
User Guide

Local
Template

Product 4
User Guide

Local
Template
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Other Format Issues

Assuming your organization has templates, the people responsible for those
templates (generally referred to as Template Administrators) don’t want users
to modify the templates because this would allow non-uniform documents to
be created. Other issues, such as conversion to HTML or Structured
FrameMaker documents present other reasons to avoid user modification of
templates or introduction of non-standard formats within a document.

To convert to HTML, WebWorks Publisher uses the format name to map the
content to a specific appearance (HTML tag) in HTML. If the format name is
not in the conversion list, the result will not look correct.

To convert unstructured FrameMaker files to structured FrameMaker, you map
unstructured formats to element names. If the format name is not in the
conversion table, the document will not convert correctly.

A Tour of FrameMaker

In the following exercises, you will look through a FrameMaker document, a
FrameMaker book, and become more familiar with FrameMaker’s tools.

Exercise 5 Starting FrameMaker

1 Start the FrameMaker application using the method appropriate for your
platform.

When you launch FrameMaker for the first time, FrameMaker prompts you to
choose either the standard FrameMaker interface or the Structured
FrameMaker interface.

2 If you are presented with a choice, click FrameMaker. When FrameMaker
starts, skip to Exercise 6 on page 9.

Macintosh In the Finder, open Applications (MacOS9) > Adobe >
FrameMaker 7.0 > FrameMaker 7.0

UNIX In a command shell, execute $FMHOME/bin/maker &

Windows From the Start menu, select Programs > Adobe > FrameMaker 7.0
> FrameMaker 7.0
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3 If you are not presented with a choice and the FrameMaker menu bar (UNIX:
the main window) indicates you have the standard interface, as shown below,
skip to Exercise 6 on page 9:

4 If you are not presented with a choice and the FrameMaker menu bar indicates
you have the Structured interface, as shown below, do the following:

a. From the File menu select Preferences. For Macintosh and Windows,
pull right to General.
The Preferences dialog box displays.

Macintosh

UNIX main window

Windows

Structured Interface in Windows title bar

The added menu item “Element” indicates the Structured
FrameMaker interface for Macintosh

Structured Interface indicator
in UNIX main window
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b. From the Product Interface pop-up menu, select FrameMaker.

c. Click Set.

d. FrameMaker prompts you to quit and restart FrameMaker to use the new
interface choice.

e. Exit FrameMaker. From the File menu, select Exit. (UNIX: in the main
FrameMaker window, click Exit.)

f. Restart FrameMaker.
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Exercise 6 FrameMaker Tools and Setup Suggestions

In this exercise, you’ll learn about some of the FrameMaker window tools and
some setup suggestions.

1 From the File menu, select Open (UNIX: in the Main window, click Open).

2 In the Open dialog box, select ../fm101/ch1/sg.using-formats.fm
and click Open. (In Macintosh, select Show All Files to display the files.)
The document displays, as shown in the example below.

The Paragraph Catalog button
displays a scroll list of the paragraph
formats used to format entire
paragraphs.

The Character Catalog button displays a
scroll list of the character formats used to
format characters within a paragraph.

The Graphic Tools Palette button
displays drawing tools and graphics
properties.

The Equations Palette button displays the
Equation editor, used to create and modify
equations.

The Status Bar contains information
about the text at the insertion point,
including, flow tag, paragraph
format, character format, and
conditional text setting. An asterisk
displays if the format contains an
override.

The Page Status area displays the current
page number and total page count for the
document. An asterisk indicates unsaved
changes in the document.

The Zoom Controls set the viewing
magnification of the document.

The Page Buttons display the previous
page or next page of the document.

Paragraph Catalog button
Character Catalog button
Graphic Tools Palette button
Equations Palette button

Status Bar Page Status Page
Buttons

Zoom
Controls
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3 From the View menu, select Borders.
The document displays with non-printing rectangles around text frames and
graphic objects.

Turning on the borders will show you where you can enter text, where to place
graphics, and the boundaries for table cells. Initially, the page may appear to
be more cluttered, but once you get used to it, your mind will filter out that
information. If you need to see how the printed page will look, turn off the
borders.

4 From the View menu, select Text Symbols.
The document displays with non-printing text symbols.

At first you may wonder what are all those things on the page and why do you
need them? We encourage you to turn on Text Symbols to get used to seeing
these symbols and to allow your mind to filter out that information until it is
needed. These symbols help you see where you have tabs, ends-of-paragraphs,
ends-of-flows, and forced returns, all of which commonly appear in
documents. These symbols take on greater importance with Markers, Suppress

Text Frame borders

Main Text Frame
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Hyphenation symbols, Anchored Frame anchors, and table anchors. The
symbols take on crucial importance when you use Conditional Text in your
documents. When you switch between views of a document, the Conditional
Markers tell you that you have some conditional text hidden from view. If you
turn off the symbols and delete text, you could inadvertently delete some
conditional text!

5 From the View menu, select Rulers.
The document displays without the document rulers.

Rulers can help you lay out text frames and graphics on Master Pages, which
control the overall appearance of a page. When you are not laying out master
pages, rulers occupy precious screen space without contributing anything.
Turn off rulers when you open a document to have more room to view your
work. When you need the rulers, simply turn them on. Turn them off when you
are finished.

Text Symbol Description

Anchored frame or table anchor

Discretionary Hyphen

§ End of flow

¶ End of paragraph

Forced line return

Marker

Suppress Hypenation

Tab

T

T
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6 Use the Zoom Controls to zoom the document to a comfortable setting.

To Zoom In one setting, click the uppercase Z. Zoom in to a comfortable
setting, such as 100% or 120%. To zoom out one setting, click the lowercase z.
When you view documents at the same zoom level, you can correlate the on-
screen dimensions to the actual on-paper measurements more easily.

7 You can also zoom to a specific level; click the 100% button.
The Zoom pop-up menu displays.

From this menu, you can select any of the preset zoom levels.

Zoom Out
(one level)

Zoom In
(one level)
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8 To specify preset zoom levels, click Set.
The Zoom Menu Options dialog box displays.

In this dialog box, you may specify any zoom level from 25% to 1600%.

The zoom level you choose depends on your screen resolution, monitor size,
and platform.

9 When you have finished setting your zoom options, click Set. (If you didn’t
change any of the settings, click Cancel.)

10 From the Zoom pop-up menu, select Fit Window to Page.
This resizes the document window to the page size at
the current zoom setting. The advantage of this setting
is when you Page Down through a document, you will
see the entire page. If you have a small monitor or your
monitor is set to a low resolution, you may not be able
to use this setting.

11 For Windows users: resize the application window to display as much of the
first page of the document as your monitor will allow.
After you have gained some familiarity with the application window later in
this book you will arrange your desktop for maximum efficiency.

The last things we recommend users do is turn off FrameMaker’s toolbars.
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12 On the View menu, see if there
is a check mark next to
QuickAccess Bar. If so, do
nothing. If not, select
QuickAccess Bar. Also on
the View menu, see if there is a
check mark next to Formatting
Bar. In so, do nothing. If not,
select Formatting Bar.

The toolbars display.

These two bars contain buttons that allow you to access many of
FrameMaker’s tools. However, these toolbars also allow you to create format
overrides (see Understanding Format Overrides on page 62); format overrides
can create large headaches later on and are best avoided. Also, these bars take
up space that could be used for document viewing. All of the tools on these
bars can be called up with keyboard shortcuts or by clicking and dragging
from the menu.

13 For now, turn off the QuickAccess Bar and Formatting Bar.

a. From the View menu, select QuickAccess Bar.

b. From the View menu, select Formatting Bar.

Exercise 7 Viewing a FrameMaker Document

In this exercise, you’ll page through a FrameMaker document and learn more
about the tools you’ll use every day.

When you first open a document, FrameMaker displays the first page, with
your insertion point at the beginning of the file.
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1 Look in the lower left-hand corner of the document window, at the status bar.

The status bar indicates the following information:

As you become more familiar with FrameMaker, you’ll use the status bar to
obtain information about objects in the document and formatting information
of the text at the insertion point.

2 Go to page 12 in sg.using-formats.fm using one of the following
methods.

• From the View menu, select Go To Page.

Flow: A Flow Tag name Identifies linked blocks of text (text
frames) on separate pages or on
the same page

¶: Chapter Number Paragraph Format Identifies the name of the format for
the paragraph
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• Click the Page Status area, as shown below:

• Use the keyboard shortcut Control-g.

The Go To Page dialog box displays.

a. In the Page Number box, enter: 12

b. Click Go or press Return.
Page 12 of the document is displayed.

3 In the fifth paragraph down from the top of the page, put your insertion point
in the word Bold, as shown below:

4 Look in the status bar; an example is shown below:

The status bar indicates flow tag A, that the current paragraph is formatted
with the Body Paragraph Format, and the text at the insertion point is
formatted with the Character Format of Bold.

Page Status area

This is an example of Bold.¶
insertion point
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In FrameMaker, it is important to use only the Paragraph Formats and
Character Formats that are defined in the template. To make some text bold
and other text italic, rather than apply a hard-coded format, which cannot be
globally managed, use a Character Format, which can be globally modified.
You’ll learn more about this in Chapter 3 Formatting and Editing Text on
page 61.

5 From the File menu, select Open.
The Open dialog box displays.

6 In the Open dialog box, double-click ../fm101/ch1/sg.standard-
solutions.fm.

7 Depending on your platform, the document window may be too small to view
text. Zoom the document to 100% or 120% by selecting the zoom level from
the Zoom pop-up menu. Also from the Zoom pop-up menu, select Fit
Window to Page.

8 Turn on Borders and Text Symbols. From the View menu, select Borders.
From the View menu, select Text Symbols.

9 In the middle of the page, put your insertion point in the red overbar text
MetaPhase, as shown below:

10 Look in the status bar; an example is shown below:

The status bar indicates that the text at the insertion point is “tagged” with the
Conditional Tag of Europe, the flow tag A, and that the current paragraph is
formatted with Body.

Conditional Tags are applied to text and the conditionally tagged text can be
displayed or hidden; by hiding one condition and displaying another, you can
create multiple versions of a document, and share content that appears in all
versions.

In this example, a company creates three products that are identical except for
the product name and distribution channels in each of three world markets,
North America, Europe, and Asia. The remainder of the document is the same
for all markets. Conditional text can be used to create a version of the
document, one for each market that displays the correct name for the product

insertion point

Condtags (USCAN, Asia, and Europe) applied to it. ¶

Our newest product MetaPhaseFazeLogicCompuFaze is now available
through software retailers in EuropeAsiaNorthAmerica.¶
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and the distribution channel through which users can obtain the product. The
text that is different for each market is tagged with the appropriate conditional
tag. To produce a document for North America, text that has been tagged for
Europe and Asia is hidden, while leaving North American tagged text
displayed.

11 Make sg.using-formats.fm active.

12 Press Page Down twice to go to page 14.

13 Near the middle of the page, put your insertion point anywhere in the table.
FrameMaker uses Table Formats to control the appearance of tables.

14 From the Table menu, select Table Designer.
The Table Designer displays.

The Table Designer is used to create, maintain, and apply Table Formats.

The TableTag box indicates that the current table is formatted with Format A.

15 Close the Table Designer.

The format
for the
current table
is indicated in
the TableTag
box
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16 In the table, double-click the text in the cell to the right of RevDate,
7/25/2003.
The Variable dialog box displays.

This is a FrameMaker Variable, not editable text.

Variables are used to name and format a string of text. The variable is stored in
one location and used in multiple locations. When the text needs to be
modified, it is modified in one place (the Variable dialog box), rather than
where it is used (in text). You’ll learn more about variables in Chapter 5
Reducing Manual Text Entry on page 141.

17 Close the Variable dialog box by clicking Cancel.

18 Go to page 2-18.
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19 In the table, in the last row, double-click the text in the second cell.
The entire block of text is selected and the Cross-Reference dialog box opens.

Variables and Cross-References cannot be edited like normal text. They use
special dialog boxes to control their content and appearance.

20 Close the Cross-Reference dialog box by clicking Cancel.

21 Look in the Page Status area. What does the asterisk indicate?
The asterisk indicates that this document has unsaved changes.

22 From the File menu, select Save.
The asterisk in the Page Status area is removed.

23 From the File menu, select Close.

Exercise 8 Opening and Working with a FrameMaker Book

In this exercise, you’ll learn about the Book window. The book window is an
organizational tool that controls logically related FrameMaker files. A book
treats multiple, separate physical files like one logical file.

1 From the File menu, select Open.

2 In the Open dialog box, select ../fm101/ch1/styleguide.book
(Macintosh: select Show All Files).

Source document for
the Cross-Reference

Source Paragraph
Tag for the Cross-
Reference

Source Paragraph
for the Cross-
Reference

Format for the
Cross-Reference
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3 Click Open.
The styleguide.book window displays. You may need to resize the book
window to display all the files shown below.

The book window contains all the FrameMaker files for the FrameMaker
Book, styleguide.book.

You can also open files from the book window.

4 In the styleguide.book window, double-click sg.using-
formats.fm. This is the same document you opened and closed in a
previous exercise.
The file sg.using-formats.fm displays.

When FrameMaker files are assembled into a book, you can work with the
separate files as if they are one file. This includes, spell-checking, finding and
changing, and paging through the document.

Icon for normal
FrameMaker

document

Icon for
generated file
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5 Press Page Up.
An information box displays.

6 In the information box, click Yes.
The last page of the document preceding sg.using-formats.fm
displays. This document is named sg.using-formatsCTOC.fm, which is
a chapter-level table of contents or CTOC.

7 Notice that sg.using-formatsCTOC.fm displays at a different level of
magnification.

8 Zoom the window to 100% or 120% using one of the following methods: In
the Zoom Controls area:

• Click the 160% button and select 100% or 120%
• Click the small z button until the button to the right reads 100% or 120%

9 From the Zoom pop-up menu, select Fit Window to Page.

10 Move to the first page of sg.using-formatsCTOC.fm using the shortcut
appropriate for your platform, shown below:

The layout of sg.using-formatsCTOC.fm is similar to the layout of the
chapter.

11 Move to the last page of sg.using-formatsCTOC.fm using the
appropriate shortcut.

Platform Shortcut

Macintosh Press the Home key

UNIX Press Shift-Page Up

Windows Press Alt-Page Up

Platform Shortcut

Macintosh Press the End key

UNIX Press Shift-Page Down

Windows Press Alt-Page Down
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12 Press Page Down to display sg.using-formats.fm. (You may have to
press it more than once depending on whether an entire page is displayed in
the document window.)

Exercise 9 Setting Up Preferences and View Options

There are two types of options you can set for FrameMaker: preferences and
view options. Preferences specify certain aspects of how FrameMaker works
on your platform and view options specify the appearance of individual
documents. An easy way to differentiate between the two settings is this:

• Preferences are specific to your computer

• View options are specific to each document

First, you’ll learn some Preferences settings.

1 Make sg.using-formats.fm active. Open the Preferences dialog box for
your platform using the appropriate menu selection shown below:

The Preferences dialog box displays:

Macintosh and Windows From the File menu, select Preferences > General

UNIX From the File menu, select Preferences

Windows Preferences
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There are two essential preferences: Automatic Backup on Save and
Automatic Save.

Note: For Macintosh
versions of
FrameMaker, Network
File Locking is not
available

Macintosh Preferences

Note: For UNIX
versions of
FrameMaker, Network
File Locking is
automatically on and
is not displayed in the
Preferences dialog
box

UNIX Preferences
(SUN Solaris shown)
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Automatic Backup files are created when you select the Automatic Backup
on Save option. A backup file is created the first time you save the file; the
backup file is unaffected by manual or automatic saves and is updated to match
the original file only when you quit FrameMaker. As long as you don’t quit
FrameMaker, the backup file remains as it was before you started working.
Even if you close the document, the backup file is not altered. When you quit
FrameMaker, file, the two files are synchronized to have the same content.

If you made a change to a file then saved or closed the file, but later realized
that you didn’t want the change, as long as you haven’t quit the application,
you can open the backup file and go back to where you were when you started
the FrameMaker application.

2 Confirm that Automatic Backup on Save is selected.

Autosave files are created when you select the Automatic Save option. The
file is used when FrameMaker or the operating system crashes and either
no .recover file exists or the .recover file is not usable. Keep in mind
that the autosave file may not have whatever work you did between the last
time FrameMaker created or updated the autosave file and the time the system
or FrameMaker crashed.

Note: Using the Revert to Saved feature will revert to the last manually saved version,
NOT the autosave.

3 Confirm that Automatic Save is selected. In the box to the right, type: 15
FrameMaker will automatically save your work every 15 minutes.

Note: By turning on Automatic Backup on Save and Automatic Save, you’ll
see these files in the same directory as the original file.

Preference Setting Notes Filename

The original file file.fm

Automatic Backup on Save (on) The backup filename file.backup.fm

(Part of FrameMaker; not a
preference)

The file created if
FrameMaker crashes

file.recover.fm

Automatic Save (on) The file created by Automatic
Save

file.auto.fm

Network File Locking
(on in Windows, by default in
UNIX, not available in
Macintosh)

The file created when
Network File Locking is on
and the file is open on
desktop (or when operating
system or FrameMaker
crashes and doesn’t clean up
properly)

file.fm.lck
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Other options and their suggested settings are shown below:

4 When you have finished specifying options, click Set.

In previous steps, you set three view options for sg.using-formats.fm,
borders, text symbols, and rulers, but that was for only one document. Other
documents in the book do not have the same view options, as you experienced
when you opened sg.using-formatsCTOC.fm.

Option Description Setting

Cross-platform file
naming (Mac:
Compatibility
Preferences >
Cross-Platform)

Warns against using filenames that may not work with the
platform you have chosen, as shown below:

UNIX

Save FrameImage
with Imported
Graphics (M+W)

Saves a bitmap of the graphic along with the graphic. If the file is
opened on a platform that does not support the graphic’s format,
the bitmap FrameImage is displayed.

Off

Show File
Translation Errors
(Macintosh only)

Displays a window that lists how unavailable fonts are
reformatted when the file is opened.

Off

Network File
Locking

Prevents other users from opening a file that is already in use.
This option is automatically on in UNIX. This option is not
available in Macintosh; we recommend that you set up some kind
of document management system to prevent inadvertent
overwriting of files.

On (Windows
only)

Remember
Missing Font
Names

When fonts used in a document are not available on the platform,
checking this box will retain the original font name. If a document
does contain unavailable fonts, the following warning dialog box is
displayed:

On
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5 From the book window, open X.resources.fm.
Depending on your platform, the document window may be minimized or too
small to see any text.

6 Manually resize the document window using the method appropriate for your
platform:

The document displays at an 80% zoom level.

7 From the book window, open sg.master-pages.fm.
The document displays but only part of the document is visible because the
window is smaller than the document page. Also, in both X.resources.fm
and sg.master-pages.fm, borders and text symbols are not turned on.

8 Set the View Options for all the documents in styleguide.book.

a. Make the styleguide.book window active.

b. Hold down Shift and from the File menu, select Open All Files in
Book.
All the files in styleguide.book are opened on the desktop.

c. Make the styleguide.book window active.

Platform Method

Macintosh Click the bottom right-corner (sometimes called the grow box) and
drag it down and to the right

UNIX Click and drag any of the four corners to resize the window

Windows Click and drag any of the four corners or sides to resize the window
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d. From the Edit menu, select Select All > Files to select all the files in the
book.
All the files in the book window are selected.

e. From the View menu, select Show Borders.

f. From the View menu, select Show Text Symbols.

g. From the View menu, select Show Rulers.

h. From the View menu, select Hide Rulers.

Explanation: The rulers were turned on in only one of the documents. To turn them
off in all documents, first you select Shown Rulers to turn them on in all documents,
and then Hide Rulers to turn them off in all documents.

i. Zoom all documents in the book to your preferred setting. From the View
menu, select Zoom > 100%. (To zoom to a higher setting, after you select
Zoom > 100%, select Zoom > In.)
This displays all the documents at the same zoom setting.

j. From the View menu, select Zoom > Fit Window to Page.
This sets each document window to be the same size as the document
page.

Explanation: Fitting the document window to the page is especially important for
Windows users because even though the application window and the document
window(s) can be sized independently, the document window remains inside the
application window. In Mac and UNIX versions, the document window(s) can be
anywhere on the desktop.
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9 With the book window active, hold down Shift and from the File menu, select
Save All Files in Book.
The book’s status bar displays the filename as it is saved.

10 With the book window still active, hold down Shift and from the File menu,
select Close All Files in Book.

11 With the book window active, from the File menu, select Close Book.

Practice Exercise

Use the following exercise to explore other View Options settings.

Exercise 10 Changing View Options

1 From the ../fm101/ch1 directory, open view-opts.fm.

2 With view-opts.fm active, from the View menu, choose Options.
The View Options dialog box displays.

Page Scrolling displays document pages by scrolling
Horizontally, Vertically, or allowing the window size to

determine which method is used. You can also
display Facing Pages.

Display Units specifies all document measurements
to be displayed as Metric (cm or mm), Inch, Pica,

Point, Didot, or Cicero.

Font Units specifies the units for Font-related
measurements (such as Font size, line spacing, and

space above and below)

Variable is the most
versatile

Inch is the most
common setting

Point is recommend

Grid Spacing specifies the invisible grid spacing.
Used for quickly positioning objects.

Rotation specifies the smallest increment of rotation
available when free rotating an object.

Turn on/off rulers display. The pop-up menu
specifies the increments displayed on the ruler.

Turn on/off visible grid display. The pop-up menu
specifies the increments of the grid lines.

Turn on/off text symbols.

Turn on/off display of graphics in a document. Default
is on. If you turn off graphics display, a blank area

displays and graphics will not print. If you print a
document that has missing graphics, a grey box

displays but does not print.

Snap to grid can be
turned on or off
easily. This is used
only for page layout
or positioning
graphics in an
anchored frame

Rulers and grid
lines are not
needed during
content creation,
but borders and
text symbols should
be left on.

Turn on/off object borders.
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3 From the Display Units pop-up menu, choose Inch.
This option sets the unit of measurement used in dialog boxes.

4 Leave the Font Units set to Point.
This option sets the display measurement of all line spacing settings, space
above and below paragraphs, font size, and table cell margins to be Points.
This means that you do not have to type in a measurement when you change
the value for any of these settings.
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5 Check (select) Grid Spacing and in the box to the right, delete pc.
This specifies the invisible snap grid to be 0.25 inch because you set Display
Units to be Inch.
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6 From the Rulers pop-up menu, choose 1/8".
This option specifies the ruler markings to display in 1/8 inch (0.125 inch)
increments.

You can also display or hide the rulers from the View menu (View > Rulers)
or by right-clicking (Mac: Control-clicking) with your cursor outside all text
frames and selecting Rulers.
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7 From the Grid Lines pop-up menu, choose 1/4".
This setting turns on a non-printing, visible grid with 1/4 inch (0.25 inch)
spacing between lines.
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8 Check (select) Borders on Objects and Text Symbols.

The last two options can be set from the View menu (View > Borders and
View > Text Symbols) or by right-clicking (Mac: Control-clicking) with
your cursor outside all text frames and selecting Borders and Text Symbols.
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9 Click Set.
The document rulers are visible with 1/8" increments, text symbols display,
text frame and graphic borders display, and the grid lines display with 1/4"
spacing. The next time you open a dialog box or window, the settings will
display in inches, rather than in picas.

Note: All View Options settings are per document. Other documents are not affected
by the settings in this document.

10 From the File menu, select Close.
A dialog box displays asking you if you want to save your changes before
closing.

11 In the dialog box click No (Mac: click Don’t Save).
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Review Questions

Answer the following questions to review what you learned in this chapter.

1 How do you prevent the text frame borders from printing? How do you prevent
the text symbols from printing?

2 When do you need rulers? How do you display them? How do you hide them?

3 How is FrameMaker different from text processing applications?

4 Name the following common text symbols:

5 Name some ways to display the first page of a document.

6 Name three ways to move to a specific page in a document.

7 What is the fastest way to open all the files in a FrameMaker book?

8 Look at the example shown below.

What is it? What information does it tell you?

9 What is the name of the FrameMaker tool that allows you to organize many
separate files and treat them like one file?

The answers to these questions are on page 339.

Text Symbol Description

§

¶

T


